Sep 27, 2011

Non funziona mai niente

Tra ieri e oggi avro' provato 20 volte a spedire un telegramma tramite il sito di Poste Italiane, ovviamente senza riuscirci. Si', capita di dover spedire un telegramma. Nel 2011.
Cio' che apparentemente e' un'operazione semplicissima (inserire il testo del telegramma, l'indirizzo del destinatario, pagare) diventa un vero calvario per il povero sito poste.it. Nei miei vari tentativi, gia' l'autenticazione iniziale spesso ha richiesto inspiegabili lunghissime attese. Era da un po' che non accedevo, e all'ingresso del sito mi veniva richiesto di procedere alla conferma dei miei dati personali per poter usufruire delle nuove funzionalita': dopo aver rifiutato alcune volte, alla fine mi sono sottoposto anche a questa procedura - vuoi mai che fosse questa la ragione del malfunzionamento. Ecco il risultato:


Tornando al telegramma: una volta entrati, si puo' cliccare su un comodo link apposito. Dopo un'attesa gia' di per se' sospetta, si viene portati alla schermata dove inserire il testo. Si clicca "avanti", e parte un'altra attesa... circa un minuto... e si arriva al momento di inserire il destinatario. Scrivi il nome, la via, selezioni la provincia e... tutto si pianta. Un'altro minuto di attesa mentre il sito carica la lista dei comuni della provincia selezionata. Si sceglie il Comune, e altro interminabile freeze. Se non siete fuggiti urlando e il browser non s'e' impallato, il sito seleziona da solo il CAP corretto e potete cliccare nuovamente su "Avanti": un'altro minuto di attesa. Qui solitamente il browser alza bandiera bianca, nelle maniere piu' svariate.








Il massimo a cui sono riuscito ad arrivare e' stata la schermata di conferma del telegramma nella quale cliccare "Conferma Pagamento" per poter dare questi maledetti tre euro alle Poste. Oltre quella, hic sunt leones. Ho persino provato a lasciare li' la pagina a caricare e uscire fuori a cena. Dopo tre ore era ancora li', invariata: non un messaggio di errore, non un timeout, niente. Ho provato con IE, con Chrome, con Safari.




Ora mi chiedo: ma chi e' che ha fatto questo sito? E' mai possibile che una funzionalita' cosi' di base sia realizzata in modo cosi' insufficiente? E' questo il livello dell'e-commerce e dei servizi telematici al cittadino in Italia? Cosa ci dice questo sullo stato dell'evoluzione tecnologica ed economica del nostro Paese? Cosa ci dice questo sui dirigenti di Poste Italiane, committenti di questo sito?

1 comment:

ilgioa said...

Per onor di cronaca, oggi 14/11 tutto ha funzionato senza problemi.